Vraag Logcat kan app- of pakketnamen niet detecteren


Ik gebruik Android Studio (Beta) 0.8.7 en mijn logcat werkt al maanden prima. Plots kan mijn logcat geen app- of pakketnamen detecteren. Dit betekent dat ik de berichten voor de specifieke app die ik test niet kan filteren, wat erg vervelend is. Typische logcat-berichten zien er nu als volgt uit:

enter image description here

Let op het vraagteken (?) Waar de app / pakketnaam moet zijn ...

Oorspronkelijk dacht ik dat het mijn apparaat was, maar ik heb het geprobeerd met een ander Android-apparaat dat ik bezit en ik krijg hetzelfde probleem. Dit is wat ik heb geprobeerd:

  • Start Android Studio en mijn computer opnieuw op
  • Doden en starten van de ADB-server vanaf de terminal
  • Start de apparaten opnieuw op

Heeft iemand dit eerder ervaren? Help alstublieft, want het maakt me een beetje gek ...

UPDATE: Ik heb mijn laptop geprobeerd waarop Android-studio is geïnstalleerd en het doet hetzelfde! Ik ben er ongeveer 95% zeker van dat de naam van de app / het pakket er moet zijn in plaats van het vraagteken, want zo herinner ik me het. Ook met een vraagteken kan de logcat geen berichten filteren op de pakketnaam van de app ... Ik heb dit probleem in het verleden nooit gehad dus het moet gewerkt hebben, dus ik kan niet gek worden ...


31
2017-08-26 11:32


oorsprong


antwoorden:


Zelfde probleem hier met Android Studio 1.0 RC2. De Apparaatmonitor geeft de naam van de toepassing weer, maar in het logcat-paneel van Android Studio is de pakketnaam altijd een vraagteken.

Ik loste het probleem op met Hulpmiddelen controleren / Android / ADB-integratie inschakelen en vervolgens adb opnieuw opstarten.

Een eenvoudigere manier is om elke app te debuggen, als ADB-integratie is uitgeschakeld, vraagt ​​Android Studio u om in te schakelen.

U moet ADB-integratie inschakelen om debugging te starten. Wil je dat doen?

Klik op Ja, natuurlijk.


33
2017-12-04 10:28



Check in je "tools -> Android"als je de optie hebt ADB-integratie inschakelen gecontroleerd - dat was mijn geval, dat om de een of andere reden de pakketnaam niet zichtbaar was, zoals in jouw geval.

Ik denk dat er misschien een sneltoets is die het effect wisselt, omdat ik zeker weet dat ik dit zelf niet heb veranderd, maar het probleem werd opgelost door handmatige controle van de optie en het opnieuw starten van de emulatie (druk op uitvoeren).


5
2018-02-05 10:56



Liep hetzelfde probleem op Android-studio. Gedwongen verbinding maken met de emulator (Intel-emulatorafbeelding met virtualisatie) en de app op de emulator gestart en zien of het toepassingsveld terugkomt naar logcat door te loggen met uw app

Vergeet ook niet om - android: debuggable = "true" toe te voegen onder de toepassing in uw AndroiManifest.xml

Eclipse ziet dit probleem niet omdat Eclipse blijkbaar automatisch fouten opspoort


4
2017-08-26 11:49



Wat ik deed: Eerst probeerde ik ADB-integratie. Toen startte ik het apparaat opnieuw op en het werkte. Mijn mening: ik denk niet dat ADB-integratie het zal oplossen.


0
2018-01-03 11:43



Een antwoord is te vinden hier (# 4)

Er staat: "ADB-integratie inschakelen in: Hulpprogramma's / Android / ADB-integratie inschakelen"


0
2018-01-25 15:47



Ik heb daar hetzelfde probleem mee.

Nu heb ik opgelost door de Debug-modus te gebruiken. Na het uitvoeren van de foutopsporingsmodus kunt u voor altijd in de normale modus werken. U ziet de naam van de toepassing nu in Logcat.


0
2018-05-16 10:03



Dit is wat voor mij werkte: Mijn tools / Android / ADB-integratie inschakelen was al aangevinkt, maar de pakketnaam was niet op log cat. Ik maakte ADB-integratie ongeschikt en klikte opnieuw om ADB-integratie opnieuw in te schakelen (aanvinken). Magisch genoeg was de pakketnaam er in log cat. Niet zeker of dit voor iedereen werkt.


0
2018-06-12 15:02



Niet van bovengenoemde methode (1: schakel ADB-integratie in, 2: gebruik debug-modus) werk .... Het wordt normaal alleen "willekeurig". Heeft iemand dezelfde situatie als de mijne?

**** Update de methode werkt voor mij ******

  1. sluit de eclips (ik gebruik het voor mijn andere java-project)
  2. in terminal, typ "adb kill-server"
  3. herstart de Android Studio.

0
2017-09-25 17:11



Deze vraag heeft me geholpen met mijn probleem en ik zou graag mijn bescheiden toevoeging toevoegen over het oplossen van dit probleem wanneer het opnieuw verschijnt zelfs met ingeschakelde ADB-integratie.

Start gewoon Android Studio voor emulator. ik gebruik Genymotion (2.6.0) en gebruikt om het eerder te starten Android Studio (2.1.2) in mijn situatie werd deze bug onthuld.


0
2018-06-17 18:13