Vraag "make" installeren op Mac


Ik probeer Memcached op Mac te installeren met behulp van deze tutorial: http://tugdualgrall.blogspot.de/2011/11/installing-memcached-on-mac-os-x-and.html maar als ik het probeer ./configure het zegt: configure: error: geen acceptabele C-compiler gevonden in $ PATH wanneer ik het probeer te laten zeggen: maken sh: make: commando niet gevonden sh-3.2 # yum install make sh: yum: opdracht niet gevonden sh-3.2 # apt-get install make sh: apt-get: commando niet gevonden

Ik moet vermelden dat ik Xcode heb, maar het werkt nog steeds niet. Ik ben echt nieuw op Mac dus houd daar rekening mee :) Ik zou je hulp erg op prijs stellen Bedankt!


28
2017-07-15 18:32


oorsprong


antwoorden:


Als u Xcode 4.3 of nieuwer hebt, worden de opdrachtregelhulpprogramma's, zoals make, standaard niet geïnstalleerd. Ga in Xcode-voorkeuren naar het tabblad "Downloads" en onder "Componenten" druk je op de knop "Installeren" naast "Opdrachtregelhulpprogramma's". Nadat u de opdrachtregelhulpmiddelen hebt gedownload en geïnstalleerd, moet u ook de volgende opdracht in de terminal typen om ervoor te zorgen dat al uw Xcode-opdrachtregelhulpprogramma's worden geschakeld om de 4.3-versies te gebruiken:

sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer

Zodra alles met succes is geïnstalleerd, zou u het moeten zien make en andere opdrachtregelontwikkelaarstools in / usr / bin.


83
2017-07-15 19:20



Van torrey.lyons's antwoord, in Xcode -> Voorkeuren -> Downloads er staat onder Commandoregel-tools:

Alvorens te installeren, merk op dat je vanuit Terminal de   XCRUN-tool om compilers en andere tools te starten die zijn ingesloten in de   Xcode-applicatie. Gebruik het XCODE-SELECT-gereedschap om te definiëren welke versie   van Xcode is actief. Typ 'man xcrun' vanuit Terminal om erachter te komen   meer.

Daarom kon ik het gereedschap Maken met het commando uitvoeren xcrun make.


3
2018-01-29 12:50