Vraag Ondersteunt Visual Studio 2010 MVC 5?


Mijn vraag is of we een applicatie in Visual Studio 2010 kunnen ontwikkelen met MVC 5?

Zo ja, vermeld ook de tutorial of voorbeeldcode url met uw antwoord.

Zo nee, specificeer dan de vereisten van MVC 5 om er een applicatie mee te bouwen?


25
2018-01-03 07:45


oorsprong


antwoorden:


Nee, dat is niet mogelijk. U hebt Visual Studio 2012 nodig en ik dacht tenminste .NET 4.5. Zie de upgrade-opmerkingen voor gedetailleerde informatie http://www.asp.net/mvc/tutorials/mvc-5/how-to-upgrade-an-aspnet-mvc-4-and-web-api-project-to-aspnet-mvc-5-and- web-api-2


31
2018-01-03 07:48



Je hebt VS 2012 of hoger nodig om MVC5-ondersteuning te hebben.


12
2018-01-03 07:49



Van de EF-blog

Verenigbaarheid

Deze versie van het NuGet-pakket is volledig compatibel met Visual   Studio 2010 en Visual Studio 2012 en kunnen worden gebruikt voor toepassingen   richten op .NET 4.0 en 4.5.

Sommige functies zijn alleen beschikbaar bij het schrijven van een toepassing die   doelen. NET 4.5. Dit omvat ondersteuning voor enum, ruimtelijke gegevenstypen,   tabelwaardige functies en de prestatieverbeteringen.

Ik kon via NuGet EF5 toevoegen aan een MVC4-project. Je kunt het zeker gebruiken MVC 4, je krijgt gewoon niet alle nieuwe functies, tenzij je op VS2012 bent.

Verschil MVC3 VS MVC4


7
2018-01-03 07:50