Vraag Visual Studio 2015 is erg traag


Ik heb net de installatie voltooid en de hele IDE is super langzaam. Het lijkt alsof het een soort van zware CPU-oproepen op de achtergrond doet, waar de hele IDE letterlijk bevriest en gedurende ongeveer 2-3 seconden niet reageert.

Ik had dit probleem niet met Visual Studio 2013 Ultimate. Ik voer Visual Studio 2015 Professional uit.

Geïnstalleerde add-ons / pakketten:

  • Node.js Tools
  • ReSharper

Heeft iemand ideeën?


140
2017-07-22 03:52


oorsprong


antwoorden:


Mijn Visual Studio 2015 RTM was ook erg traag met ReSharper 9.1.2, maar het werkte prima sinds ik een upgrade naar 9.1.3 heb uitgevoerd (zie ReSharper 9.1.3 to the Rescue). Misschien een keu.

Nog een cue. Een ReSharper 9.2-versie is beschikbaar gemaakt voor:

verfijnt de integratie met Visual Studio 2015 RTM, waardoor problemen worden aangepakt   ontdekt in versie 9.1.2 en 9.1.3


36
2017-07-27 13:55



Ik ontdekte dat Windows Defender Antimalware enorme vertragingen veroorzaakt. Ga naar Update & Beveiliging -> Instellingen -> Windows Defender. Open de Defender en kies in de instellingenselectie Uitsluitingen en voeg het proces "devenv.exe" toe.


88
2018-06-05 05:41



Probeer de ReSharper-codeinspectie uit het menu uit te schakelen opties → Code Inspectie → omgeving en kiezen voor Visual Studio IntelliSense (menu Keuze → intellisense → Algemeen) in plaats van ReSharper IntelliSense maakt het veel sneller.


23
2017-08-19 13:32



Probeer ook een van beide te verwijderen Node.js Tools voor Visual Studio (NTVS) of de commerciële add-on genaamd ReSharper van JetBrains. Het gebruik van zowel NTVS als Resharper veroorzaakt geheugenlekken in Visual Studio 2015.

NTVS = Node Tools voor Visual Studio


18
2017-07-22 04:22



Ik heb zeer trage bewerkingen met Visual Studio 2015 Community Edition ervaren, vooral tijdens het werken met HTML (en ook Razor) en JavaScript. Ik kon het probleem oplossen door de verwijzingen in het bestand "Scripts / _references.js" van mijn ASP.NET MVC-project te verwijderen. Verder heb ik autosync in dat bestand uitgeschakeld door dit toe te voegen aan de top van het bestand _references.js.

Deze oplossing zorgt ervoor dat IntelliSense van Visual Studio niet alle JavaScript-verwijzingen bevat die beschikbaar zijn. ReSharper's IntelliSense werkt echter prima en snel.

/// <autosync enabled="false" />

16
2017-10-02 17:04



Als je lijdt als gevolg van ReSharper dan kunnen onderstaande opties helpen.

Visual Studio-configuratie:

ReSharper kan conflicteren met de andere Visual Studio-add-ons en extensies - in het geval van vertragingen, probeer de andere add-ins een voor een uit te schakelen en controleer of het helpt Visual Studio met ReSharper te versnellen. Hier zijn enkele voorbeelden van bekende compatibiliteitsproblemen met andere addins:

Power Tools voor productiviteit

VSCommands

U kunt ook proberen de volgende opties uit te schakelen onder "Extra |   Opties | Omgeving | Algemeen ": Visueel automatisch aanpassen   ervaring op basis van clientprestaties Gebruik hardware-afbeeldingen   versnelling indien beschikbaar

ReSharper-configuratie.

Hoewel ReSharper nogal wat krachtige en nuttige functies biedt, kunnen sommige van deze worden aangepast of uitgeschakeld in termen van het verbeteren van de snelheid. Hier zijn enkele voorbeelden:

Schakel Solution Wide Analysis (SWA) uit in "ReSharper | Opties | Code   Inspectie | Instellingen ", 'Analyseer fouten in hele oplossing' checkbox

Schakel terug naar Visual Studio IntelliSense in "ReSharper | Opties |   Omgeving | IntelliSense | Algemeen "dialoogvenster Caches wissen voor   huidige oplossing in "ReSharper | Opties | Omgeving | Algemeen"   dialoog

Hier zijn de links:


6
2017-07-06 11:15



Dit lijkt dom, maar na het verwijderen C:\Users\{User}\AppData\Local\Microsoft\WebSiteCache alles begon weer snel te gaan. Als je geen opties hebt, kun je dat proberen. Het is het enige dat voor mij werkte.


4
2017-08-05 00:46



Hetzelfde probleem hier, Visual Studio 2015 Pro Update 2 op een geheel nieuwe machine. De editor was extreem traag en typte als kauwgom.

De reden hiervoor was ESET NOD32 Antivirus 9. Het heeft een ding genaamd "Host Intruder Prevention System (HIPS)" standaard ingeschakeld. Ik weet niet hoe nuttig dit is, maar het kan worden uitgeschakeld of ik heb gewoon een regel toegevoegd om toe te staan devenv.exe.

Nu gaat het goed.


3
2018-06-11 14:38



Ik had een soortgelijk probleem, maar alleen bij het opstarten;

Om mijn startprobleem op te lossen:

Ik heb extensies uit Visual Studio 2012 voor telefoons verwijderd;

Repareer Visual Studio 2015 zelfde ... Visual Studio 2015 verwijderen (ophangen, niet allemaal verwijderd)

Gebruik dan:

https://github.com/tsasioglu/Total-Uninstaller

Verwijder alles wat mogelijk was met Visual Studio 2015, Visual Studio 2013, enz.

Fout in Visual Studio opnieuw installeren: logboeken, inet, enz. Opzoeken en Visual C ++ redist 2015 gevonden. Ik heb vc_redist.x64.exe en vc_redist.x86.exe opnieuw geïnstalleerd en gerepareerd.

Ik heb Visual Studio 2015 opnieuw geïnstalleerd en nu heb ik geen opstartproblemen (vsHub kan worden verwijderd en verbonden services kunnen worden uitgeschakeld ...)


3
2017-11-02 13:12



Ik had hetzelfde probleem met VS 2015 Community met Node Tools.

Ik zag een aantal problemen over dit probleem in de ghtub-repository van NTVS en het kan te maken hebben met het analysebestand in het project. In feite heb ik dit bestand bij elke projectlading verwijderd en het wordt sneller, maar ik denk dat de veiligste manier om het te verbeteren, sommige mapbestanden zoals de onderstaande link negeert.

https://github.com/Microsoft/nodejstools/wiki/Projects#ignoring-directories-for-analysis


2
2018-04-01 13:00



Dit komt waarschijnlijk omdat u enkele SQL Server-componenten hebt verwijderd die Visual Studio gebruikt. Hoewel Visual Studio nog steeds werkt, is het erg traag.

Ga gewoon naar "Programma's en functies" in het Configuratiescherm en repareer Visual Studio. De benodigde Visual Studio-componenten worden opnieuw geïnstalleerd en Visual Studio is net zo snel terug als daarvoor.


2
2017-12-15 09:05