Vraag Fout bij het installeren van Maven Integration for Eclipse


Ik probeer Maven-integratie voor Eclipse (Galileo) te installeren Install New Software menu nad met behulp van de sonatype-link

http://m2eclipse.sonatype.org/sites/m2e

En volgende foutmelding krijgen:

De installatie kan niet worden voltooid omdat een of meer vereiste items niet kunnen worden gevonden.
    Software die wordt geïnstalleerd: Maven-integratie voor Eclipse (vereist) 0.12.0.20101115-1102 (org.maven.ide.eclipse.feature.feature.group 0.12.0.20101115-1102)
    Ontbrekende vereiste: Maven-integratie voor Eclipse (vereist) 0.12.0.20101115-1102
  (org.maven.ide.eclipse.feature.feature.group 0.12.0.20101115-1102) vereist 'org.eclipse.emf.ecore.edit 0.0.0' maar het kan niet worden gevonden

Probeerde te zoeken naar de ontbrekende bundel. Maar geen succes. :(

Alle hulp?


21
2017-11-28 15:35


oorsprong


antwoorden:


Vink in uw installatiemanager "Contact opnemen met alle updatesites ..." aan en probeer het opnieuw. Aangezien EMF afkomstig is van een andere updatesite dan M2Eclipse, kan M2Eclipse niet worden geïnstalleerd zonder de mogelijkheid om alle updatesites te controleren op vereiste componenten.


BIJWERKEN!

Sinds Eclipse 3.7 (Indigo) wordt m2e nu gehost op eclipse.org. Om het te installeren, hoeft u alleen de standaard Eclipse-updatesite te gebruiken:


50
2017-11-28 17:03



Gebruikt u Eclipse CDT? Als dit het geval is, moet u ervoor zorgen dat de Java-ontwikkelhulpmiddelen ook zijn geïnstalleerd. Ervan uitgaande dat u Helios gebruikt, gebruik http://download.eclipse.org/releases/helios/ als een updatesite en installeer de JDT-tools uit de lijst met functies onder "Programmeertalen". Ik had hetzelfde probleem en dat loste het voor mij op.


7
2017-12-06 22:30



Sinds Eclipse 3.7 (Indigo) wordt m2e nu gehost op eclipse.org. Om het te installeren, hoeft u alleen de standaard Eclipse-updatesite te gebruiken:

http://download.eclipse.org/releases/kepler
http://download.eclipse.org/releases/juno
http://download.eclipse.org/releases/indigo
etc.

Daarom, voor het verkrijgen van maven in eclipse indigo, verwijzen we u naar het antwoord gemarkeerd in gele kleur, samen met screenshot op onderstaande link

eclipse indigo marketplace Maven Integration-installatiefout


5
2018-05-13 06:55



Ik heb hetzelfde probleem (tussen haakjes, "contact opnemen met alle updatesites" is standaard). Ik vond dit bugrapport in eclips-bugzilla, wat aangeeft dat we een probleem hebben in de plug-in zelf.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=330896

Een workaround voor mij is om terug te vallen op oudere versies van m2eclipse / m2eclipse extras / subversieve integratie. Ik heb de volgende URL's gebruikt:


3
2017-11-29 13:35



de meerderheid van de zonsverduistering is niet van toepassing op Mven 3.5 en 1.8. om maven te installeren moet je naar halp gaan - installeer nieuwe software Naam: m2eclipse plaats: http://download.eclipse.org/technology/m2e/releases/1.4

voor helios: http://download.eclipse.org/technology/m2e/releases/1.3


1
2017-10-31 13:06



Om de nieuwe m2e (1.4) op helios te installeren, moest ik alle maven-elementen in eclipse verwijderen en vervolgens kon ik m2e installeren van http://download.eclipse.org/technology/m2e/releases".

Stappen voor het verwijderen van bestaande maven-elementen (van org.maven.ide. *):

  1. Klik in Help in eclipse
  2. Installeer nieuwe software ...
  3. Klik op Wat al is geïnstalleerd
  4. Selecteer alle items van org.maven.ide. * (Zelfs als dit Vereist is)
  5. verwijder ze allemaal

0
2017-12-24 13:47



Een andere manier om de Maven plug-in voor Eclipse te installeren:

  • Open Eclipse
  • Ga naar Help -> Eclipse Marketplace
  • Zoeken op Maven
  • Klik op de knop "Installeren" in het gedeelte "Maven Integration for Eclipse"
  • Volg de instructies stap voor stap
  • Na een geslaagde installatie doet u het volgende in Eclipse:
    • Ga naar Venster -> Voorkeuren
    • Observeer, Maven wordt ingelijfd bij het linkerpaneel
    • Klik op een bestaand project
    • Selecteer Configureren -> Converteren naar Maven-project

0
2017-12-13 09:17



Zorg ervoor dat u vinkje bij alle installatielocaties vinkt tijdens het installeren om de aanvraagsoftware te vinden voordat u klikt op de volgende installatie van Maven Integration voor Eclipse & m2e-slf4j via logboekregistratie (optioneel).

ik stond voor hetzelfde probleem, op dit moment is het opgelost door het bovenstaande te doen. Ik hoop dat dit nuttig zal zijn.


0
2017-07-26 14:50