Vraag Grails 3.0.1 toevoegen in Eclipse show error Opgegeven directory lijkt geen Grails-installatie te zijn


Wanneer ik Grails 3.0.1 in Eclipse installeer / importeer, krijg ik een foutmelding "Opgegeven directory lijkt geen Grails-installatie te zijn".

Ik heb Groovy Compiler 2.4.3 al geïnstalleerd. maar krijg nog steeds dezelfde foutmelding.

Hoe kan ik Grails 3.0.1 installeren in Eclipse 4.4?


13
2018-04-08 08:05


oorsprong


antwoorden:


In de map grails kun je een bestand "build.properties" plaatsen,

/grails-3.0.1/build.properties
             /install
             /license
             /.......

de inhoud van dit bestand is een enkele regel "grails.version = 3.0.1", zonder aanhalingstekens. :-)

Nu zal eclips het herkennen als Grails-installatie.

vriendelijke groeten


46
2018-05-08 21:02



Grails 3 verschilt sterk van eerdere versies van Grails, met name op basis van Spring Boot. Het zal nog een tijdje duren voordat de IDE's ondersteuning hebben voor Grails 3. Eclipse heeft waarschijnlijk geen ondersteuning voor Grails 3 omdat 3.6.4 is aangekondigd als de laatste release van GGTS en de Grails and Groovy tooling nu Pivotal Grails and Groovy heeft verlaten .


11
2018-04-08 08:56



Ik gebruik de meest platte ggts van sping (3.6.4) de graduele plug-in (geïnstalleerd over het dashboard van de lente) en de nieuwste snapshot-versie van de groovy plug-in voor eclips om een ​​groovy 2.4-compiler te krijgen.

Met deze setup importeer je je grails3-applicatie als graduele applicatie voor mij.


1
2018-04-08 16:57



Dit zijn de stappen voor het werken met Grails 3 in Eclipse. 1) Verkrijg de laatste grails 3.X-versie en setup in het systeem. 2) Creëer nu de Grails-app met behulp van de opdrachtregel. 3) Installeer de Gradle-plug-in in eclipse als deze er nog niet is. 4) Project importeren als Gradle in eclipse, Gradle downloadt alle benodigde afhankelijkheden.


1
2018-04-23 13:24