Vraag Git ssl-fout in windows


Ik krijg de volgende foutmelding wanneer ik probeer een git-repository te klonen met ssl in windows:

error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

De SSL-certificaathiërarchie is vertrouwd (het uitgevercertificaat is toegevoegd aan Vertrouwde basiscertificaatautoriteiten) en ik kan naar de hostingsite (een privé-instantie van Gitorious) bladeren zonder SSL-fouten. Ik heb klonen geprobeerd in Windows 7 en Windows Server 2008 en het is beide keren mislukt.

Heeft iemand ideeën?


13
2017-09-23 08:23


oorsprong


antwoorden:


Git Blijkbaar geen certificaten die in Windows zijn opgeslagen, moet u opgeven wat het pad naar het certificaatbestand moet worden bewerkt .gitconfig

gitconfig locatie:

C:\Program Files (x86)\Git\etc

Voeg de regel toe (vervang door het pad naar bestand en uwCertificaat.ctr met de naam naar uw certificaat):

.
.
.
[help]
    format = html
[http]
    sslVerify = true
    sslCAinfo = C:/Program Files (x86)/Git/bin/curl-ca-bundle.crt
    sslCAinfo = [route]/yourCertificate.crt
[sendemail]
    smtpserver = /bin/msmtp.exe

[diff "astextplain"]
.
.
.

en probeer opnieuw..


17
2017-09-25 15:21



Als u Linux of Mac OS gebruikt, kunt u in terminal typen:

export GIT_SSL_NO_VERIFY=1
git clone https://some.repository

Op windows:

Right click on My Computer -> Properties -> Advanced System settings -> Environment Variables
Add variable GIT_SSL_NO_VERIFY with value 1

6
2017-09-23 08:36



Zorg ervoor dat je toevoegt aan je Git global config-bestand:

 http.sslcainfo=/bin/curl-ca-bundle.crt

Uw msysgit-instantie moet weten waar de CA-certificaten moeten worden gezocht om ze te valideren.

Bekijk hier meer instellingen ZO antwoord of in "Kan Http niet op git krijgen om te werken".


0
2017-09-23 08:49



De locatie van http.sslcainfo is opgeslagen in "C: \ ProgramData \ Git \ config". Het is niet gewijzigd bij het verwijderen / opnieuw installeren van git.

Ik moest het onlangs veranderen

sslCAInfo = C:/Program Files/Git/mingw64/ssl/certs/ca-bundle.crt

naar

sslCAInfo = C:/Users/kristof/AppData/Local/Programs/Git/mingw64/ssl/certs/ca-bundle.crt

Zie ook het probleem:
Configureer http.sslcainfo in Git voor Windows 'eigen systeemomvattende configuratie # 531
https://github.com/git-for-windows/git/issues/531


0
2017-11-26 13:19



Als al het andere faalt, kunt u de omgevingsvariabele instellen GIT_SSL_NO_VERIFY naar true. Het is echter hopelijk mogelijk om het probleem op een andere manier op te lossen. WAARSCHUWING: Hiermee wordt u blootgesteld VEILIGHEIDSRISICO'S, omdat je niet langer kunt vertrouwen dat je praat met de server waarmee je denkt te praten.


-1
2017-09-23 08:32