Vraag Voeg onveilig register toe aan Docker


Ik heb een docker 1.12 op CentOS. Ik probeer een onveilig register toe te voegen en dingen die in de documentatie worden vermeld, werken gewoon niet. Het systeem gebruikt systemd dus ik heb een gemaakt /etc/systemd/system/docker.service.d/50-insecure-registry.conf het dossier.

$ cat /etc/systemd/system/docker.service.d/50-insecure-registry.conf
[Service]
Environment='DOCKER_OPTS=--insecure-registry="hostname.cloudapp.net:5000"'

Na het laden van de daemon en het herstarten van de docker-service, laat systemd zien dat de omgevingsvariabele aanwezig is

$ sudo systemctl show docker | grep Env
Environment=DOCKER_OPTS=--insecure-registry="hostname.cloudapp.net:5000"

Maar als ik ren docker info Ik zie niet dat onveilige register toegevoegd

$ docker info
........
Registry: https://index.docker.io/v1/
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled
Insecure Registries:
    127.0.0.0/8

Afbeeldingen naar duwen hostaneme.cloudapp.net faalt met

Pushing application     (hostname.cloudapp.net:5000/application:latest)...
The push refers to a repository     [hostname.cloudapp.net:5000/mozart_application]
ERROR: Get https://hostname.cloudapp.net:5000/v1/_ping: http: server gave HTTP response to HTTPS client

Is er iets dat kan worden gedaan? Mis ik iets ?

BIJWERKEN

Het probleem opgelost door een bestand toe te voegen /etc/docker/daemon.json met de volgende inhoud

{
    "insecure-registries" : [ "hostname.cloudapp.net:5000" ]
}

En herstart dan docker

sudo systemctl daemon-reload
sudo systemctl restart docker

Na dat onveilige register hostname.cloudapp.net:500 werken.


41
2018-02-13 18:51


oorsprong


antwoorden:


(Kopiëren antwoord op vraag)

Voeg het bestand toe om een ​​onveilig docker-register toe te voegen /etc/docker/daemon.json met de volgende inhoud:

{
    "insecure-registries" : [ "hostname.cloudapp.net:5000" ]
}

en start docker opnieuw.


66
2018-04-18 21:05



Het maken van /etc/docker/daemon.json bestand en het toevoegen van de onderstaande inhoud na een herstart van een docker op CentOS 7 loste het probleem op.

{
    "insecure-registries" : [ "hostname.cloudapp.net:5000" ]
}

1
2018-06-08 03:05